home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-libs / gdbm-1.8.3-r2 / gdbm-1.8.3-r2.ebuild < prev    next >
Text File  |  2005-10-13  |  1KB  |  51 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.3-r2.ebuild,v 1.3 2005/10/06 02:42:19 vapier Exp $
  4.  
  5. inherit eutils libtool multilib
  6.  
  7. DESCRIPTION="Standard GNU database libraries included for compatibility with Perl"
  8. HOMEPAGE="http://www.gnu.org/software/gdbm/gdbm.html"
  9. SRC_URI="mirror://gnu/gdbm/${P}.tar.gz"
  10.  
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc-macos ppc64 s390 sh sparc x86"
  14. IUSE="berkdb"
  15.  
  16. DEPEND="berkdb? ( sys-libs/db )"
  17.  
  18. src_unpack() {
  19.     unpack ${A}
  20.     cd "${S}"
  21.     epatch "${FILESDIR}"/${P}-fix-install-ownership.patch #24178
  22.     elibtoolize
  23. }
  24.  
  25. src_compile() {
  26.     use berkdb || export ac_cv_lib_dbm_main=no ac_cv_lib_ndbm_main=no
  27.     econf --includedir=/usr/include/gdbm || die
  28.     emake || die
  29. }
  30.  
  31. src_install() {
  32.     make INSTALL_ROOT="${D}" install install-compat || die
  33.     mv "${D}"/usr/include/gdbm/gdbm.h "${D}"/usr/include/ || die
  34.     dodoc ChangeLog NEWS README
  35. }
  36.  
  37. pkg_preinst() {
  38.     # temp backwards support #32510
  39.     if [[ -e ${ROOT}/usr/$(get_libdir)/libgdbm.so.2 ]] ; then
  40.         touch "${ROOT}"/usr/$(get_libdir)/libgdbm.so.2
  41.     fi
  42. }
  43.  
  44. pkg_postinst() {
  45.     if [[ -e ${ROOT}/usr/$(get_libdir)/libgdbm.so.2 ]] ; then
  46.         ewarn "Please run revdep-rebuild --soname libgdbm.so.2"
  47.         ewarn "After that completes, it will be safe to remove the old"
  48.         ewarn "library (${ROOT}usr/$(get_libdir)/libgdbm.so.2)."
  49.     fi
  50. }
  51.